Types of DOS that support FAT32

There are mainly three types of FAT drives: FAT12, FAT16 and FAT32. Some people used to think DOS only support FAT12 and FAT16 drives, not FAT32 drives. However, this is totally wrong. The fact is: only very old versions of DOS don't support FAT32 drives, while most newer versions of DOS support FAT32 as well as FAT12 and FAT16 drives. Below are lists of the typical types and versions of DOS that do or do not support FAT32 drives:

Part I: Typical types and versions of DOS that support FAT32 drives:

MS-DOS 7.10 | This is the most useful and up-to-date version of DOS with FAT32 and LFN (Long File Names) support, and has the best compatibility and usability. It fully supports Win3.x/9x GUI running on top.
PC-DOS 7.10 | With FAT32 support, however only a boot disk is available, and has problems with some drives and programs.
DR-DOS 7.01.x WIP/7.05/8.0 | With FAT32 support, however only a boot disk and few files are available, and has less compatibility than MS-DOS 7.10. Also, DR-DOS 8.0 is not available for download.
ROM-DOS 7.10 | With FAT32 and LFN support, however has less compatibility than MS-DOS 7.10. And only DEMO version is available for download.
PTS-DOS 32 [7.10] | With FAT32 support, however only DEMO version is available for download, with very limited utilities and less compatibility.
FreeDOS Kernel 2035 [7.10] | The most promising open-source DOS with FAT32 support, however has many limitations and bugs for the time being.
RxDOS 6.2 | With FAT32 and LFN support, however very buggy and unstable, and not complete.
Real/32 DOS 7.94 | With FAT32 and multi-tasking support, however it's not for download at all, and has much less compatibility than MS-DOS 7.10.

So, from the above table, we can know that MS-DOS 7.10 is the best DOS of all different types/versions of DOS in the world. You can install MS-DOS 7.10 from its own installer. MS-DOS 7.10 boot disks/CD and MS-DOS 7.10 Full Installation Set are available from:

Go to MS-DOS 7.10 page

Part II: Typical types and versions of DOS that do NOT support FAT32 drives:

MS-DOS 6.22 | This is a classic yet very outdated and ancient version of MS-DOS.
PC-DOS 7.0/2000 | The old and classic PC-DOS 2000 is still used by some people.
DR-DOS 7.0/7.03 | No official versions of DR-DOS support FAT32 drives.
PTS-DOS 2000 | Not used by many people, and no FAT32 support.

There is NOT any stable and usable separate FAT32 driver for these old versions of DOS (BTW: DRFAT32 is very unstable and unusable, and has no LFN support). Even if all drives are in FAT16 format, older versions of DOS will NOT be able to see or access larger hard disks, because these older DOSes don't know about LBA and Int13x calls at all. So, in order to support FAT32, LFN, large hard disks, and more useful stuff natively and stably, users should upgrade their DOS, from MS-DOS 6.22 to MS-DOS 7.10, for example. More information about MS-DOS 7.10 is available from:

Go to MS-DOS 7.10 page

Any questions, problems, or suggestions, please feel free to mail me!


MS-DOS

MS-DOS downloads

 MS-DOS 7.10 398K (Standard MS-DOS 7.10 Boot Disk) Стандартная - это наиболее практичный вариант MS-DOS.

MS-DOS 7.10 (Полная версия - 2 флоппи, включая все компоненты, такие как DOSSHELL и графическая программы установки)
MS-DOS 7.10 Это полная версия установки MS-DOS 7.1 компакт-диск CD ISO
Super MS-DOS 7.10 1.1M супер MS-DOS 7.1, занимаемое место на диске различными программами значительно сокращено, больше основной памяти 625-630K, мультизагрузка, английские длинные имена файлов (LFN), NTFS, USB,оптический дисковод, мышь. Также много весьма полезных инструментов.Это последнее издание 14 февраля 2004 года.

Back to MS-DOS 7.10 Main Page

© Wengier Новая эра DOS


MS-DOS 7.10

MS-DOS 7.10 is the best and the most up-to-date version of MS-DOS in the world. It fully supports FAT32, LFN (Long File Names), Win3.x/9x GUI and many more.

For more information about the new features, please read "What's new in MS-DOS 7.10 since MS-DOS 6.x"?

For screenshots of MS-DOS 7.10, please come to Screenshot Page.

For a list of FAT32 and LBA compatible types of DOS, please refer to DOS FAT32 Page.

Note: The downloads are no longer available. Thanks for your support.

Any questions, comments or suggestions, please mail me.


MS-DOS 7.10 Screenshots

You can view some screenshots of MS-DOS 7.10 below. Click the screenshots to enlarge the pictures. If you want more screenshots, please let me know.

Screenshot 1

MS-DOS 7.10 Animated Startup Logo (Optional)

Screenshot 2

MS-DOS 7.10 Setup is unpacking necessary files during MS-DOS 7.10 installation

Screenshot 3

MS-DOS 7.10 is started successfully and type VER to show the DOS version

Screenshot 4

MS-DOS 7.10 with full FAT32 and Long File Names (LFN) support

Screenshot 5

MS-DOS 7.10 can see/access Long File Names (LFN) on MP3 CDs

Screenshot 6

MS-DOS 7.10 with Windows for Workgroups 3.11 GUI + Win32s 1.30 running on top

Screenshot 7

MS-DOS 7.10 with WFW 3.11 GUI on top using permanent swap file and 32-bit access

Screenshot 8

MS-DOS 7.10 with Windows 95 [4.00.950] GUI running on top

Screenshot 9

MS-DOS 7.10 with Windows 98 SE [4.10.2222] GUI running on top

Back to MS-DOS 7.10 Main Page


What's new in MS-DOS 7.10 since MS-DOS 6.x?

There are many enhancements, new features and bugfixes in MS-DOS 7.10 since MS-DOS 6.x. For example:

* FAT32 and FAT32X drives support (*very* important nowadays)
* Extended FAT16 (a.k.a. FAT16X, type 0E, usually being the primary partition) drives support
* Large hard disk and LBA ExtendedX (Int 13x) partition (type 0F) support (*very* important nowadays)
* Long File Names (LFN) support
* Full Y2K (Year 2000) compliant and supports 4-digit years (e.g. DIR /4)
* Large memory (>64MB) and XXMS 3.0 support
* Euro sign support (Code Page 850, Right Alt+5)
* The protection that keeps the stability of DOS
* Efficient use of UMB memory (The DOS kernel and COMMAND.COM are loaded high automatically)
* Extended commands in CONFIG.SYS to use UMB memory, such as FILESHIGH, BUFFERSHIGH
* Environments variables can be used in the DOS command line directly, e.g. ECHO %PATH%
* The maximum length for path variable is expanded
* Some new commands added, such as ACCDATE, LOGO(in CONFIG.SYS)
* Volume LOCK/UNLOCK feature added to protect data and LFN on the (hard) disks
* EDIT can be used to edit both text and binary files and multiple files
* REN can rename a directory as well as files
* The locations of DOS system files (especially IO.SYS) are much more flexible
* Dual-boot with older versions of MS-DOS (e.g. DOS 6.x) feature added
* Animated startup logo support by using a custom LOGO.SYS file
* You can decide whether to execute a command using Enter/ESC key now while using the step-by-step feature
* Support for loading Win9x GUI (including all versions from Win95/95A to Win98SE GUI) on top added
* Many undocumented but useful options and switches added, such as COMMAND /Z
* Updated and newer versions of DOS commands and tools included, such as MORE, MSCDEX, MSD
* And many more...

Back to MS-DOS 7.10 Main Page